Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm having issues installing apache2, and pretty much everything in general, I'm using debian.

I run sudo apt-get install apache2 and then it returns

root@debian:~# apt-get install apache2
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 apache2 : Depends: apache2-mpm-worker (= 2.2.16-6+squeeze7) but it is not going to be installed or
                    apache2-mpm-prefork (= 2.2.16-6+squeeze7) but it is not going to be installed or
                    apache2-mpm-event (= 2.2.16-6+squeeze7) but it is not going to be installed or
                    apache2-mpm-itk (= 2.2.16-6+squeeze7) but it is not going to be installed
           Depends: apache2.2-common (= 2.2.16-6+squeeze7) but it is not going to be installed
E: Broken packages

Not really sure what's up :S Seems like it can't find any of the required packages for anything,

Anyone know what I'm doing wrong?

share|improve this question
    
information you provided is a bit confusing. Can you show apt-get install output? –  DukeLion May 21 '12 at 14:12
1  
Did you do an apt-get update before? Also, please post your /etc/apt/sources.list as an edit to your question. –  SvW May 21 '12 at 14:12
    
Also, try apt-get -f install or even aptitude install ; either way you /should/ get a little more information than this. –  Shadur May 21 '12 at 14:42
    
Does sudo apt-get install apache2 apache2-common apache2-mpm-prefork work? –  EightBitTony May 21 '12 at 15:44
    
Try sudo apt-get update && sudo apt-get install apache2 apache2-mpm-prefork apache2-utils apache2.2-common –  Vishal May 24 '12 at 10:37
add comment

1 Answer 1

up vote 1 down vote accepted

it would be quite helpful if you could also provide us with the output of the aptitude update command and also include the contens of /etc/apt/sources.list

share|improve this answer
    
sources.list issue, thanks I managed to fix it –  Belgin Fish May 27 '12 at 20:50
    
This is really a comment, not an answer. With a bit more rep, you will be able to post comments. –  Scott Pack Oct 30 '12 at 20:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.