Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am geeting the folowing error when i tried installing beanstalkd (sudo apt-get install beanstalkd) and I even tried -f option but none helped what can id do

Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  beanstalkd: Depends: libevent-1.4-2 (>= 1.4.13-stable) but it is not going to be installed
  mysql-server-5.1: Depends: mysql-client-5.1 (>= 5.1.62-0ubuntu0.10.04.1) but it is not going to be installed
                    Depends: libmysqlclient16 (>= 5.1.21-1) but it is not going to be installed
                    Depends: mysql-server-core-5.1 (>= 5.1.62-0ubuntu0.10.04.1) but it is not going to be installed
                    PreDepends: mysql-common (>= 5.1.62-0ubuntu0.10.04.1) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
share|improve this question
    
What version of Ubuntu are you on? Have you run apt-get update? Are you using any third-party repositories? –  Shane Madden May 21 '12 at 22:23
add comment

1 Answer

up vote 0 down vote accepted

You need to resolve dependencies manually.

try to install listed dependencies, using

aptitude install libevent-1.4-2
aptitude install mysql-common
aptitude install mysql-client-5.1
aptitude install libmysqlclient16
aptitude install mysql-server-core-5.1

Installation of some of this will may fail - you probably will need to install it manually using dpkg -i /var/cache/apt/archives/packagename.deb

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.