Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm running a FreeBSD server with Apache and PHP 5.3. I'm trying to get the Oracle DB extension (OCI8) running with PHP but I can't find a port or anything for it. Half of the Internet says it's no longer supported the other half is complaining about segmentation faults. I'm at a loss here.

Even a link to a little bit of relevant info will be helpful. I'm hoping for a PHP solution otherwise we'll have to go the Java route.

Thanks!

share|improve this question
1  
The OCI extension is baked into PHP. However, Oracle doesn't support FreeBSD, so there's no client, which is why the port doesn't give the OCI option. A third party got something working for PHP5.2, but it wouldn't have been supported by Oracle. You can try contacting that port provider and see if they're putting something out for 5.3, but seeing that 5.4 is out, I doubt it. If you're running the Linux compat layer you can install the Linux client and manually compile PHP with OCI enabled, but it's a chore and would be quite complicated. –  Chris S May 21 '12 at 16:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.