Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to test the Windows deployment services in Windows 2008 R2. I am able to get an IP when my desktop PXE boots but then I get PXE-E32: TFTP open timeout.

Has anyone run into this? if so anyone know a fix?

Thanks

share|improve this question

4 Answers 4

up vote 5 down vote accepted

If you have DNS and WDS running on the same box, a patch from over last summer (the DNS exploit patch) can cause this to happen. The fix for this is on Johan Arwidmark's blog. Hope that helps. Good luck.

share|improve this answer
    
That fixed it...thanks for your help!! –  Patrick Jul 10 '09 at 20:49

I had the same issue on our Windows 2008 R2 Server. The fix from Johan Arwidmark Blog worked. I changed the range from 64001 - 65000 to 60000 - 65000

share|improve this answer

This can be caused by the DNS patch, but the fix in the Johan Arwidmark's blog isn't quite correct. The DNS patch causes the DNS process to bind to 2500 random ports when the service starts, which has a small chance of overlapping with the WDS port range.

To fix this, you need to increase the size of the port range for WDS to something larger then 2500 ports to make sure it will work.

share|improve this answer

The article (blog) is updated to reflect new configuration options in Windows Server 2008 R2, as well as an explaination to the problem and updated instructions for Windows Server 2003 and Windows Server 2008.

http://www.deployvista.com/Default.aspx?tabid=70&EntryID=66

Regards / Johan Arwidmark

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.