Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to switch an IIS configuration over to using application pools instead of application protection.

When I right-click the "Web Sites" node and go into Properties, then Service tab, I uncheck the "Run WWW service in IIS 5.0 isolation mode" setting. Clicking Apply, I'm prompted to restart IIS. After restarting, if I go through the same steps, the checkbox is still there. It does switch to listing application pools (until the next time I re-open the IIS Manager) but it shows "Application Protection" instead of "Application Pool" when trying to configure a site or virtual directory.

Why isn't IIS storing my setting to not use IIS 5 isolation?

share|improve this question
I actually have the exact opposite problem... here is my question – Saul Dolgin Nov 15 '12 at 16:33
up vote 1 down vote accepted

The setting change you made is not persisted because the IIS metabase file on disk has not been updated before the IIS restart occurs. The change is only retained in the in-memory IIS metabase cache at first. A forceful restart of IIS will result in losing your change.

I have answered my "opposite problem" question on ServerFault with the solution to this root cause.

Also, see here for Microsoft KB 286196 which outlines a workaround.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.