Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

i'm using openstack, but i think this is a more general problem. Actually i've a dedicated which comes with 1 ip address, i bought another one, and added using openstack's nova-manage cli.

So now this is what i get

$ ip addr
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 00:30:48:fc:4c:92 brd ff:ff:ff:ff:ff:ff
    inet 188.165.x.x/24 brd 188.165.225.255 scope global eth0
    inet 94.23.x.x/32 scope global eth0
    inet6 fe80::230:48ff:fefc:4c92/64 scope link
    valid_lft forever preferred_lft forever

so it seems that both ip are binded to eth0, the problems is that i don't receive packets with destination set to 94.23.x.x, when i run tcpdump -i eth0 i see packets to both ip, when i run tcpdump -p -i eth0, so not in promiscous mode, i see packets to only the first ip, so dnat and what i need won't work.

If i try to ping 94.23.x.x on the host works fine, from outside gives timeout.

Any idea?

Best Regards

EDIT:

$ ip route
default via 188.165.x.254 dev eth0  metric 100 
188.165.x.0/24 dev eth0  proto kernel  scope link  src 188.165.x.x 
192.168.3.0/24 dev br100  proto kernel  scope link  src 192.168.3.1 
192.168.4.32/27 dev br100  proto kernel  scope link  src 192.168.4.33 
192.168.122.0/24 dev virbr0  proto kernel  scope link  src 192.168.122.1
share|improve this question
    
Can you provide the output of ip route as well? –  mgorven May 21 '12 at 21:56
    
@mgorven done that, second ip shouldn't have route as i have to bind as /32 –  alex88 May 21 '12 at 21:58
    
Try do a tracepath to the two IPs. –  mgorven May 21 '12 at 22:46
    
@mgorven it's the same, packets arrives and i can see in promiscous mode, but there is no reply as in not promiscous mode it doesnt receive them. –  alex88 May 21 '12 at 22:51
    
Is there a firewall? –  mgorven May 21 '12 at 23:43

2 Answers 2

up vote 0 down vote accepted

Can you check, what is destination MAC address on packets you receiving in tcpdump in promiscuous mode?

If it's destination MAC is not correct: 00:30:48:fc:4c:92 - you have an IP conflict and should contact your provider.

If it's correct - you have problems on your side, e.g. wrong NIC, ip, kernel settings, maybe incorrect netmask or routing problems.

share|improve this answer
    
You're right, check this paste pastebin.com/10R7xngE the mac is different, that's why it drops the packets? can be that? –  alex88 May 22 '12 at 7:06
    
Ok, it's an IP conflict - ip address is used somewhere else. You provider need to resolve it, or give you another IP address. –  DukeLion May 22 '12 at 7:12
    
i'm not sure about that, i have another server with eth0 with mac 90:e6:x:x:x:x which is on a bridge (vmbr0), the bridge uses the same mac as eth0 and i've added a vmbr0:0 ip, i can see it correctly receive packets to that ip, but the packets has a different mac as destination 02:00:x:x:x:x and they're not dropped. –  alex88 May 22 '12 at 7:15
    
Hmm, sounds a bit strange to me. But regardless, default behaviour of ethernet NIC is to drop all packets not destined to it's mac address. Promiscuous mode allows it to accept all packets. Also it will work on bridge interface, since bridge interfaces should be in promiscuous mode to work. –  DukeLion May 22 '12 at 7:19
    
i've tried to use pastebin.com/TCQa1FCu and set ifconfig eth0 promisc, still no logs, packets seems to be dropped –  alex88 May 22 '12 at 7:25

You have your second IP set up with a /32 netmask. which will pretty much prevent it from doing anything unless you're trying to host it as a loopback (..and your upstream is routing it to you).

Your provider should have given you a subnet mask with the second address you purchased. When you get it set up then your system should be able to ping other hosts in that 94.23.x.x subnet.

share|improve this answer
    
Nope, I have to use it as /32 because it's routed to my server, this is my hosting provider guide about alias ip help.ovh.com/IpAlias –  alex88 May 21 '12 at 22:26
1  
@alex88 no, rnxrx really is correct. A /32 netmask will drop traffic because of reverse path filtering. Also you cannot route the traffic back out as with a /32 netmask you cant reach external machines. Also that guide you linked is general purpose, and seems to be written to cover adding IPs in general, not your exact case, and so should be taken as such. –  Patrick May 21 '12 at 23:17
1  
@patrick time ago i've set with different netmask and they've closed server for not needed arp packets.. The additional ip is just to make machine respond to request coming to thAt ip, not reach external machines using that ip as source.. –  alex88 May 21 '12 at 23:22
1  
@Patrick I don't think that reverse path filtering is involved here, because the default route goes out eth0. In any case, the filtering is on the source IP, not the destination IP. –  mgorven May 21 '12 at 23:59
    
@alex88 In this case the second IP address is not alias because the primary address is from diferrent subnet. –  0xFF May 22 '12 at 5:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.