Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I need to open port 10011 for an application called Teamspeak 3 to work.

I'm using CentOS and i tried the following commands :

sudo iptables -I INPUT -p tcp --dport 10011 -j ACCEPT

i pressed enter, the console went to a new line, no errors, no output. still, when i use a website to check if that port is open, it's not opened.

Is there anything i'm doing wrong or i might have overlooked ?

Thank you.


EDIT : here is what iptables -L gives me ( i have removed some lines for security reasons.)

Chain INPUT (policy ACCEPT 0 packets, 0 bytes)
 pkts bytes target     prot opt in     out     source               destination
    0     0 ACCEPT     tcp  --  any    any     anywhere             anywhere            tcp dpt:10011
share|improve this question
add comment

migrated from stackoverflow.com May 22 '12 at 1:21

This question came from our site for professional and enthusiast programmers.

1 Answer

Don't start by using a website to check if that port is open.

  1. Start with your local system:

    $ netstat -tln
    

    This should you all listening ports on your system. Do you see an entry for port 10011? It will look something like:

    tcp        0      0 0.0.0.0:10011               0.0.0.0:*                   LISTEN      
    

    If you don't see that, you've got a problem. If you do see that, move on to the next step:

  2. Use telnet to try connecting to the local port to make sure a locally originated connection works. Try this:

    $ telnet localhost 10011
    

    If something is listening on that port, this should report:

    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.
    

    If instead it reports:

    Trying 127.0.0.1...
    telnet: connect to address 127.0.0.1: Connection refused
    

    Then you probably have a problem with the application.

  3. Is local connectivity working? Great! Now you should ideally perform the same test from another host on your local network:

    $ telnet a.b.c.d 10011
    

    Where a.b.c.d is the ip address of your system. If this fails, you probably have a local firewall problem. If it works, move on to step 4.

  4. If connectivity on the local network is working, the remaining possibility is that there is a router or firewall between you and the outside world that is configured to block inbound traffic. Do you control your network connectivity? Does someone else? Verify that your network gateway will pass the traffic.

If this doesn't help out, let us know what fails and we'll work from there.

share|improve this answer
    
Nicely done as always @larsks. –  Magellan May 22 '12 at 1:49
    
Thank you for your great answer. It's very clear and helpful. I have succesfully passed step 3, but i shall check for step 4. –  darthun08 May 22 '12 at 5:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.