Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Every day, the first time that I log in to a relatively (otherwise) speedy windows 2003 server, it sits on "applying user settings" or something similar for 30+ seconds after a successfull login (before the desktop appears).

Any thoughts on how to get rid of this?

Thanks

share|improve this question
    
See serverfault.com/questions/9154/… as well –  Chealion Jul 10 '09 at 21:33

4 Answers 4

up vote 3 down vote accepted

What it displays matters.

If you're seeing "Applying personal document settings...", for example, that implies a problem with folder redirection policy.

Also, have a look at the application event log-- it's probably telling you something about what's going on.

Edit:

Okay. Is a roaming user profile in use? If so, go check to see the count of files and size of the files in the profile directory on the server computer. You've probably got a boatload of files or a very large file in your roaming profile.

share|improve this answer
    
"Applying your personal settings..." is what it says exactly. I'm checking the App Event Log –  George W Bush Jul 10 '09 at 20:40
1  
I checked the app event log and I was getting this error: "Windows cannot determine the user name or computer name" support.microsoft.com/kb/329708 ..... I fixed it by changing the DNS server in the TCP/IP connection settings for the only network card on the server. It broke remote desktop for about 5 minutes, but it works now and is quite fast. I changed the DNS server to match our other servers. We had some IT people come in and "upgrade" some things.. I guess they forgot about this. –  George W Bush Jul 10 '09 at 20:58
    
I think that Russ Warren deserves the rep. All I did was tell you what you'll now remember for the future-- the system wants to tell you what was wrong, you just have to ask it. The event logs / system logs / whatever your OS calls it should be the first place you look when problems occur, always. –  Evan Anderson Jul 10 '09 at 21:01

Have you checked that DNS is setup properly?

share|improve this answer
    
+1 - Dude-- you were robbed. You were spot on. –  Evan Anderson Jul 10 '09 at 20:59
    
Good call Russ, and now I have to hit 15 characters –  RascalKing Jul 10 '09 at 21:06
    
+1 to help makeup the diff –  squillman Jul 11 '09 at 2:50
    
So why does the DNS being setup incorrectly cause this error? Is it because it cannot find the rescources the profile wants to find and cannot? –  Matt Jul 13 '09 at 18:01
    
Correct. The local system will need to contact resources based on DNS. If the first DNS server isn't working properly, you'll have to wait for it to timeout. If the secondary server isn't working (or there isn't one), it should default to using local credentials. This is actually one of the first things I learned about troubleshooting slow logins on Active Directory. –  Russ Warren Jul 13 '09 at 18:21

Well, I am assuming you are using roaming profiles. What size is the profile on your server? Are you caching profiles locally on your domain? If you have an abnormally large profile, it can take a while to get to the machine from your file server. Also, Local profile caching can help speed it up, if you feel comfortable with that.

share|improve this answer

Anytime that I've ever had a slow down in remote desktop (when starting my connection), it's been because my RDP session was attempting to map local printers, which I don't have a need for. I turned that option off and it got rid of my slowdown.

If you click on Options > Local Resources in the RDP window, it's a check box to turn it off.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.