Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Currently I had a Windows Server 2008 R2 running in Hyper-V, previously it still able to access any kind of website with domain name. Recently, it failed to do that any more, and I found out that I can still access website with IP address, but not domain name, and once I tried manually configure the hosts file (located in system32/drivers/etc/), the domain name works again. I also tried flushdns, restart server, restart router, restart anything that I could.

Anyone know how to resolve this?

FIY: The server is a file server and deployment server, mainly for users logged in for building deployment and testing purpose. It does not have DNS server roles.

share|improve this question
    
so within the guest you don't get a result for "nslookup serverfault.com" if not do a ipconfig /all look at the dns settings are they correct? –  tony roth May 22 '12 at 4:54
    
"DNS request timed out" is the result it returned when I do nslookup, I've checked the dns setting, it's the same since the first day I configured it, and same with any other server as well. –  foo0110 May 22 '12 at 5:37
    
Are you able to see DNS traffic on your edge firewall from this server? Is it maybe blocking it for some reason? –  MichelZ May 22 '12 at 6:48
    
How do I check on DNS traffic? mind sharing? –  foo0110 May 22 '12 at 7:03
    
That depends on your firewall on how to do it, but have a look for Port 53, UDP traffic –  MichelZ May 22 '12 at 7:17
show 7 more comments

1 Answer

Open a command prompt and type "ipconfig /all".

This will list the DNS servers that your network adapter is using. If that is blank or points to somewhere strange, that is a likely source of your problem. Whatever is specified as your network adapter's DNS servers is always the place it will ask for DNS resolution, whether that destination is real or not.

The quickest way to get to where you need to fix it in Server 2008 is to open a run box and type 'ncpa.cpl'. This will fire up your network connections. Go to the properties of the problematic virtual NIC (you said this is on Hyper-V, right?), configure IPv4, and specify your DNS servers. If they are being assigned automatically, then that means DHCP isn't supplying the correct info. Manually type them in. If all you need is name resolution for websites outside your organization, Google's public DNS server of 8.8.8.8 works fine.

share|improve this answer
    
Just had the network adapter DNS for Hyper-V set to 8.8.8.8, but it is still now working, I am able to ping 8.8.8.8, but not www.google.com –  foo0110 May 24 '12 at 3:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.