Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a server running Gentoo and hosting a drupal installation. Whenever a Drupal update is executed, the directory permissions of the updated module turn from 755 to 744 preventing the application from accessing the files. The umask is defined as 022 under /etc/profile and the Apache server is running under user and group nobody.

I believe this has nothing to do with the drupal installation since if I create a directory as root, the same happens, it is created with 744 permissions, since the umask is 022 shouldn't it be created as 755 ?

Why is the umask being ignored and how do I tell the server to create the directories with permission 755 ?

share|improve this question
    
Are you updating drupal through drupal itself? –  Kyle May 22 '12 at 16:36
    
From drupal itself. –  drcelus May 22 '12 at 16:52
    
What version of Drupal? 7.x? Have you tried, just for fun, to grep -ir "chmod" /path/to/your/drupal? –  Janne Pikkarainen Jun 29 '12 at 14:32
1  
Do you run mod_umask or PHP through suPhp or similiar? these modules are setting the umask. –  Johann Jul 3 '12 at 11:39
1  
This doesnt explain how when youre in the shell as root with a umask of 022, files are created as if umask were 033... –  Patrick Jul 4 '12 at 17:41

1 Answer 1

up vote 0 down vote accepted

As per my answer to your question: check the configuration of the running Apache modules (specifically mod-umask and suphp) for umask settings.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.