Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Created a new vSwitch with no physical network adapters and no VLAN tags assigned to it. Left it at 120 ports as default, labelled it "Private Network".

Added a "Flexible" network adapter to each Ubuntu 10.x LTS (32-bit) machine (they were migrated from an older ESXi 4.0 host) with this new "Private Network" label assigned as secondary NICs on both virtual machines; put them both on the same subnet once they booted back up.

Ran iperf with the default TCP settings, -b 10M for size.

Getting a very consistent 50.6Mbps. Seems kind of lackluster for a network that should exist in memory on the host, should it not?

I thought so too, so I tried two other VMs on the same host, but these were created with ESXi 5 (VM version 8), so I used the VMXNET 3 and was getting (likely inaccurately) 34Gbps (!).

Did a quick rsync (over SSH) of a 1GB file and was getting a very nice 20.4MB/s (163.2 Mbps).

Is it the VM version or the VMXNET 3 vs. Flexible here?

share|improve this question
add comment

2 Answers

Have you actually installed the VMWare guest OS drivers in your Ubuntu VM's? That makes a veeery big difference.

share|improve this answer
    
You know, I have not checked that: I never set these up. –  gravyface May 22 '12 at 19:41
    
And I think you should be able to see well over Gigabit.. The 34 Gbps actually does not seem that "odd". The bottleneck on your system seems to be disk, which is probably why you "only" got 20 MB/s on your rsync experiment. –  MichelZ May 22 '12 at 19:46
    
yup, Dell MD3000i SAN, RAID10, slower than I think it should be, but never really got a response from a prior question of mine. –  gravyface May 22 '12 at 19:50
    
Is Flexible the only option it gave you for these vNICs? It should be giving you at least e1000 or vmxnet2.. –  Shane Madden May 23 '12 at 4:05
    
The vmxnet3 driver is the highest performing driver, but if you are using flexible it may not be using the vmxnet3 driver. –  Bad Dos May 23 '12 at 20:50
add comment

Providing you have installed VMware tools (which you absolutely should do), you should use VMXNET 3, it is supported in Ubuntu 7.04 and higher. It will give you the best network performance as it is paravirtualized instead of emulated (the E1000 is emulated).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.