Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Did anyone manage to get Opera working on Ubuntu 9.04?
It's trying to resole domain names in IPv6 way, and somehow gets a zero-reply from the gateway (ip-address of much zeroes), and fails to connect.

UPD: wireshark sniff:

8  5.647832	DNS	Standard query A
9   5.649655	DNS	Standard query response A

By the way, ALL other networking goes fine, including firefox.

One solution i found was to disable IPv6 in kernel, but in 9.04 it's impossible due to a BUG.
Can i have Opera working without rebuilding the kernel with a patch?

UPD: if I ping some host (so its IP is cached now) - Opera finds it, and opens the page OK. Maybe, there's a way to "pre-ping" everything Opera tries to connect to? :))

share|improve this question
The bug in question: – crb Jul 11 '09 at 0:55

If your NAT router is also acting as a DNS server there have been known issues with IPv6 (AAAA) resolution in many cases.

I can say that I run Opera (v9.63 & 10 beta) on a Debian machine pointing to a BIND resolver and native IPv6 and it all works fine.

share|improve this answer

"gets a zero-reply from the gateway" from your DNS server you mean ? If you dns server reply with an nul IPv6 address to AAAA request you probably have a problem on your DNS server !

share|improve this answer
I probably have a problem with my router :)) But i've read a plenty of forums where people complained they've the same problem, so i guess that's not correct – kolypto Jul 10 '09 at 23:28
I saw your edit, this ip an IPv4 resolution query, the DNS server of your router is just bugged, what kind of router is it ? – radius Jul 11 '09 at 10:18
It's Paradyne 6212. Not a fresh one :) Despite, as Andrew said, all browsers (and other network software!) work just OK, only Opera works wierd – kolypto Jul 25 '09 at 2:06
up vote 1 down vote accepted


$ opera -debugdns
dns: Host '' resolved to

This is a typical malformed response from the broken DNS implementation found on some routers. Opera first looks for ipv6, and gets the wrong reply.

The solution is to point resolv.conf to OpenDNS's DNS servers - and Now my resolv.conf looks like this:


Works like a charm! :)

share|improve this answer

I am in the same boat, opera installs, and loads, and does not connect to the net. !? Firefox ok, Epiphany ok, Thunderbird ok, Seamonkey ok, ...

share|improve this answer
I believe we should either recompile Linux Kernel without the IPv6 module, or wait for opera update :) – kolypto Jul 20 '09 at 21:41
Solved! Look here :) – kolypto Sep 1 '09 at 11:24

I've read much about that, and it seems to be a bug in 9.04 distribution. You'll have to recompile the kernel without ipv6 in order to do it.

share|improve this answer
This is a bug in opera, not 9.04. There is a bug in 9.04 (the inability to disable IPv6). Opera should however work fine with v6 enabled. – Cian Aug 31 '09 at 2:47
Alas, it works not :( A new Opera release is coming, i'm curious to see whether it works :) – kolypto Aug 31 '09 at 15:20
Already: download Opera 10, – dmityugov Sep 1 '09 at 11:13
Nah, the same problem :) But solved, see above – kolypto Sep 1 '09 at 19:49

The -debugdns switch tells me that for example is doing an IPv4 lookup first, and gets resource temporarily unavailable from gethostbyname. Hmmmm...would hope it would look up IPv6 first. Firefox goes right to it, and works OK. Sigh...there must be some bits somewhere I could change or set up to ask Opera to do an IPv6 query first. Heck...there's even an IPv6 address as the first nameserver line in my resolv.conf. My Linux router does an IPv6 tunnel, BIND, and most everything else needed for v6 connectivity.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.