Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently saw that my 2GB SanDisk microSD card was mounting as read-only filesystem on my linux (Ubuntu 10.10). I tried changing its property through nautilus, but it went in vain.

Also I tried manually editing /etc/mtab file where I edited "ro" option to "rw", but when the flash-drive was again inserted, it was mounted as read-only.

Can anyone tell me how I can remove this write-protect property of this filesystem to read-write in linux?

share|improve this question

Full sized SD cards have a write protect switch.

I do not have a microSD card here to see if they also have one. But it is worth checking. If you are using a microSD to SD convertor then also check that.

share|improve this answer


sudo mount -o remount,rw /wherever/card/is/mounted
share|improve this answer
I already tried that and got the following mount error: mount: cannot remount block device /dev/sdb read-write, is write-protected . Also I tried formatting the filesystem to FAT32 using mkfs and with gparted but in vain – freax May 23 '12 at 10:18
are there any messages in dmesg when plugging it in? – krissi May 23 '12 at 11:49
@krissi yes, as I have said I got write-protect is on when I did a dmesg as [19686.432282] sd 13:0:0:0: [sdb] Write Protect is on – freax May 23 '12 at 12:00
Can be a hardware switch, see answer of @Hennes – hayalci May 23 '12 at 21:22

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.