Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have an issue that I haven't been able to find an answer for. I have a handful of Mac designers here that started using a program called Articulate to generate flash objects to embed on our website. Articulate will create a folder, and in that folder is an html file, some javascript files and the swf file.

The designers have a single PC that they use the Articulate software on, and then they'll move the generated files to their department Share (running on a Windows Server 2008 box). Then they'll get on their macs, connect to the Windows file server via SMB and pull the file to their local computer.

The issue that is coming up is that when they pull the files from the Share to their Mac, OS X is making the permissions 700. When the users try and change the permissions using Finder > Get Info, they get a message that says it can't complete the operation, error code -50. If I use chmod from the terminal, it fixes it just fine. This is an issue because the CMS system we use depends on the files having the GROUP set to read. So with these files being copied down as 700, it's breaking the CMS.

If I create a new file or folder from the GUI or from the terminal, it applies the umask as expected and gives me 755 and 644, but through SMB it's doing 700. How can I change what default permissions are being set when they pull a file from a SMB share?

Additional Information:

On the Windows share, the folder has the Designers group with all permissions except for "change permissions" and "take ownership". The Designer will then get on their iMac and connect to the Windows fileserver using their Active Directory user, which is a member of the Designer group. Once they've pulled the share up in Finder, they find the folder they want and they drag and drop it to their local desktop. Upon inspecting the permissions of this new folder on their local machine, they have

drwxr-xr-x   63 ryan  staff   2142 May 23 09:31 .
drwxr-xr-x  337 ryan  staff  11458 May 22 16:25 ..
drwx------   5 ryan  staff     170 May 22 11:54 Folder1
share|improve this question
    
I'm a bit confused about the sequence of events here, can I suggest you include the equivalent of ls -l of the file and directory at each stage (or at least, some view of the permissions), so that people can see the progression of permissions. Include how the permissions look from both the client and the server. –  EightBitTony May 23 '12 at 16:04
    
Anecdotal input here but I've had huge trouble with MacOS clients using SMB/CIFS shares with extended permissions, eg, more than just an owner and group. Main usage here has been Mac clients writing to a Samba based server where they completely ignore extended permissions (POSIX ACLs) on the file system and will only write if they own the file or their primary group has write access. Wonder if you're setting a similar problem going the other way? –  James Yale May 23 '12 at 16:39
    
That's been the biggest problem for me because everything I search for on Apple's site or on google produces solutions to the problem you described, and not the other way around. –  Safado May 23 '12 at 19:24
    
Well, unfortunately Apple's official answer is that it surpasses what their Support is able to troubleshoot and that we can contract with their Engineers to look into at $700/incident. –  Safado May 24 '12 at 21:27

1 Answer 1

I bet the file permissions could be retained if you used something like RSYNC or something similar that has file-permissions features during a copy...

share|improve this answer
    
I believe it would work as well. Problem is, the Designers aren't your typical designers and they're pretty computer stupid. In the past I've created bash scripts on their desktop that they could double-click perform similar tasks and they complained. So preferably we're looking for a solution to the problem versus a band-aid fix. –  Safado May 23 '12 at 19:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.