Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

First of all, some info:

  • Windows Server 2008 Datacenter, 100% updated with Service Pack 2 and all the patches.
  • I connect to it using "Remote Desktop Connection" (I don't now if this is relevant)
  • I login using a user that is an administrator

The tasks in the Task Scheduler get triggered for a few days, then they don't do until I restart the operating system. Then they work again for a few days and stop, and so on.

When I open the Task Scheduler administrator, select any of the tasks, and the open the "history" tab below, I don't see any entries for the last events that should have happened, but didn't. I mean, no entries at all that would indicate that the task triggered or tried to trigger. In other words, as if the task had been totally ignored by the scheduler. All tasks seem to suffer the same.

When I open the Event Viewer, I don't see any useful information. No entries at all for all those events that never happened, no system error indications, nothing. I have checked all the relevant directories in the event viewer (the 5 windows logs and the "....\Microsoft\Windows\TaskScheduler" log. Nothing there that would explain what is wrong.

The "Task Scheduler" service started, thats for sure because the events happen for some time until they stop. Then, when they don't run anymore, I assume the service is still running but I'm not 100% sure because for some reason the stop/pause/restart/..../start commands in this service seem to be disabled (I don't know why), even though I have logged in as an administrator, so I can not try restarting the service so see of the events work again.

All other functions in the operating system seem to work fine, the RAM amount is fine, the server doesn't get unresponsive or any other bad symphtom.

Does anybody know what is the problem? I have been strugling with this failure for a long time, a year or more having to restart my server every few days.

Thanks in advance!

share|improve this question
    
What kind of triggers are you using for these tasks? –  uSlackr May 23 '12 at 18:13
    
I have the same issue. Even when the task is Run manually, nothing at all shows up in the task history, as if it didn't even try to run the task. It's not security context either. –  user145511 Nov 14 '12 at 17:20

2 Answers 2

What stands out to me in your question is "...they work again for a few days and stop...". In my experience, these types of issues are usually related to security context.

Check to make sure the "Run whether user is logged on or not." radio button is checked. I would first suspect that you're logging in as the administrative user that the task runs under, and it's fine until your session is terminated.

If that is set properly, then check to make sure the task conditions (in Task Properties) are able to be met consistently.

share|improve this answer

Do you have Windows Live installed? I was pulling my hair out over this, but then found if you disable the Windows Live \ SOXE task everything comes back to life

http://social.msdn.microsoft.com/Forums/en/winserver2008appcompatabilityandcertification/thread/6fa3c7fa-511b-498d-9b37-1201e1ff2e59

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.