Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

A real quick question! I have a physical VHOST which hosts several VM's for different purposes - they are all set to automatically load when my VHOST first boots at staggered times.

Now if I apply Windows updates across the board - my VHOST and all my VM's, meaning they all require a restart - would restarting the VHOST itself do the job? Or will HyperV just put all my VM's in a saved state and they all require a reboot individually when my VHOST loads back up?

Cheers!

share|improve this question

2 Answers 2

up vote 4 down vote accepted

it depends on how your VM's are configured. if this is just a stand-alone hyper-v server with no clustering or management from SCVMM, then when you reboot the host, the guests will do what they are configured to do. in the settings for the individual VM's, there is a section called "Automatic Start Action" and "Automatic Stop Action" that controls what happens when the host starts up or shuts down.

The defaults are "Nothing" (as in don't start the VM) for startup and "Save the virtual machine state" for shutdown.

so unless you have changed those setting from the default, then your VM's will not get rebooted.

share|improve this answer
    
Many thanks for the advice! –  PnP May 23 '12 at 18:14
    
The default for start must be wrong - I have 4 serverson, never changed that and vm's stop / start when patching reboots. –  TomTom May 23 '12 at 18:16
    
Thanks again - just checked those settings and thats helped clear some things up in my head :) Many thanks Longneck –  PnP May 23 '12 at 18:19

It depends on how you have your VMs configured. If they're set to do a full shutdown when the host shuts down, then yes, a single reboot (from your end) will reboot all of them. However, the default seems to be to save state and resume, so you might want to reconfigure that to better suit your needs.

You can change the shutdown behavior by going into the server management console, opening up the Hyper-V section, right-clicking your VM, and configuring the preferences in there.

share|improve this answer
    
Many thanks for the advice! –  PnP May 23 '12 at 18:14
    
Thanks again - just checked those settings and thats helped clear some things up in my head :) Many thanks Bigbio –  PnP May 23 '12 at 18:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.