Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

How do I get slapd to quiet down? Every second it's writing the same five lines to the /var/log/messages file.

May 24 13:16:09 servername slapd[21299]: conn=5866 op=15204 SRCH base="" scope=0 deref=2 filter="(objectClass=*)"
May 24 13:16:09 servername slapd[21299]: conn=5866 op=15204 SRCH attr=subschemaSubentry namingContexts altServer supportedExtension supportedControl supportedFeatures supportedSASLMechanisms supportedLDAPVersion vendorName vendorVersion
May 24 13:16:09 servername slapd[21299]: conn=5866 op=15204 SEARCH RESULT tag=101 err=0 nentries=1 text=
May 24 13:16:09 servername slapd[21299]: conn=5866 op=15205 SRCH base="o=od,c=us" scope=2 deref=2 filter="(|(|(|(|(cn:dn:=global)(cn:dn:=standards))(objectClass=organizationalUnit))(objectClass=organization))(&(&(objectClass=*)(cn:dn:=00026))(ou:dn:=dev)))"
May 24 13:16:09 servername slapd[21299]: conn=5866 op=15205 SEARCH RESULT tag=101 err=0 nentries=45 text=

These don't seem to be error messages to me. AFAIK, ldap is working fine. The openldap.org docs showed that I could add "loglevel 0" to slapd.conf, but that didn't help.

Any ideas how I can get this thing to shut the heck up?

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

You have search logging turned on. Turn off debugging.

You may need to edit /etc/sysconfig/openldap as well.

share|improve this answer
    
"loglevel 0"?? Already tried that. –  Ed Manet May 24 '12 at 17:33
    
Post the output of: tr "\0" \ < /proc/`pidof slapd`/cmdline –  MikeyB May 24 '12 at 17:36
    
/usr/lib/openldap/slapd -h ldap://127.0.0.1:389 -f /etc/openldap/slapd.conf -u ldap -g ldap -o slp=on od –  Ed Manet May 24 '12 at 17:37
    
"loglevel 0" didn't work, so I had to mess around with some other values. 32768 didn't turn it off. 129 seems to have help alot. Thanks for the help. –  Ed Manet May 24 '12 at 18:41
    
Check to see if you have any other loglevel lines set in a similar configuration file. It may be additive. –  MikeyB May 24 '12 at 18:56
add comment

Any ideas how I can get this thing to shut the heck up?

Many ways! Unconsciousness is perhaps the most absolute. Gags may also be effective.

For a more useful answer, consider filtering those messages: Is there a way to filter syslog entries?

share|improve this answer
    
I do like this idea and will probably make use of it elsewhere. But I think it's more direct to put the gag right in the talker's mouth, rather than put plugs in my ears. :) –  Ed Manet May 24 '12 at 18:40
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.