Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Hi i am very new to Cisco ASA 5000 series and have two interfaces that i would like to route between, a data network 192.168.69.0/24 and voice 192.168.70.0/24, I have addded both and can ping the respective gateway when on the same subnet, but if i am connect to a data switchport i cannot ping the voice vlan and vice versa.

I thought this was something to do with NAT, so i added nat exempt rules but still no dice. I lack understanding so would appreciate recommendations for books or tutorial sites/videos that will help me understand about ASA policy.

Regards,

Chris

Please find my config below:

Result of the command: "show running-config"

: Saved
:
ASA Version 8.2(5) 
!
hostname ciscoasa
names
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
 switchport access vlan 70
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.69.1 255.255.255.0 
!
interface Vlan2
 nameif outside
 security-level 0
 ip address dhcp setroute 
!
interface Vlan70
 no forward interface Vlan2
 nameif voice
 security-level 100
 ip address 192.168.70.1 255.255.255.0 
!
ftp mode passive
same-security-traffic permit inter-interface
access-list voice_nat0_outbound extended permit ip any 192.168.69.0 255.255.255.0 
access-list inside_nat0_outbound extended permit ip any 192.168.70.0 255.255.255.0 
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu voice 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
nat (voice) 0 access-list voice_nat0_outbound
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.1.0 255.255.255.0 inside
http 192.168.69.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet timeout 5
ssh 192.168.69.0 255.255.255.0 inside
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.69.5-192.168.69.254 inside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny  
  inspect sunrpc 
  inspect xdmcp 
  inspect sip  
  inspect netbios 
  inspect tftp 
  inspect ip-options 
!
service-policy global_policy global
prompt hostname context 
no call-home reporting anonymous

: end

share|improve this question

1 Answer 1

up vote 2 down vote accepted

you need the global command. with the nat (iface) command you specify which traffic is to PAT (NAT but all IPs are translated to one IP) this IP is configured with the global(iface) command for the matching nat ID: Example

nat(inside) 1 0.0.0.0 0.0.0.0
global(voice) 1 interface

any Source IP from the inside Interface will be PATed to the voice Interface IP for traffic that goes from inside to voice. It is also possible to specify an IP address with the global command

your voice vlan interface should have an other security-level, because securiyt level 0 is used for the outside interface and 100 for the inside. with nat and global configured you can access from a higher security-level interface to an lower. if you would like to access from a lower to a higher you need a static

and you will need access-lists for permit/deny traffic for example icmp:

access-list acl-inside permit icmp any any
access-list acl-voice permit icmp any any
access-group acl-inside in int inside
access-group acl-voice in int voice

cli doc: http://www.cisco.com/en/US/docs/security/asa/asa80/configuration/guide/conf_gd.html

asdm doc: http://www.cisco.com/en/US/docs/security/asa/asa83/asdm63/configuration_guide/config.htm

share|improve this answer
    
... some examples: cisco.com/en/US/products/ps6120/… –  user1008764 May 25 '12 at 17:39
    
Many thanks, that makes sense. Any particular reason people say to do routing on Layer 3 switch as opposed to firewall? Surely firewall is the only place to do routing if we wish to control traffic flow betwene subnets? Great reply, thanks for help. –  g18c May 25 '12 at 20:55
    
you are welcom. yes there are reasons why firewall shouldn't be the default gateway supportforums.cisco.com/docs/DOC-12708 –  user1008764 May 25 '12 at 21:35
    
you are welcome. yes there are reasons why firewall shouldn't be the default gateway supportforums.cisco.com/docs/DOC-12708. if your Layer3 Switch supports vfr lite you can segment vlans with vrf and connect the vrfs over the firewall so it is possible to control traffic flow between subnets. i don't know your network envirement so it's hard to say whether it is ok to use the firewall as default gateway or not. depending on your network envirement it can work fine without problems or not –  user1008764 May 25 '12 at 21:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.