Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Outlook 2010 - gives me Security alert EVERY time it's opened;

The Security certificate was issued by a company you have not chosen to trust. View the cert to determine whether you want to trust the certifying authority.

I have installed this cert to the trust Root Certification Authorities folder, and tried installing it 'automatically'; but the message persists.

Every time this user opens outlook this messages pops on his machine. Any thoughts? I have also tried not using cached mode, but the issue persisted there too.

I'm a bit clueless at this point.

Server is Windows 2008R2 running exchange.

share|improve this question
1  
When you look at the cert, who does it say issued the certificate? –  Bart Silverstrim May 25 '12 at 17:22
    
Also, what is the date/time expiration for the cert? –  Mike B May 25 '12 at 17:32
    
Yes, it's the clients exchange server that issued the cert. I realized I was placing the wrong cert into the Trusted Root Cert - once I installed the proper cert (the root cert) to that location it worked fine without issue! :) thanks! –  Hanny May 25 '12 at 17:35

2 Answers 2

up vote 1 down vote accepted

I was selecting the cert issued by the Root Authority and trying to install that as a root cert authority (which didn't work) - once I selected the Root Certificate and installed it in the proper location it worked without issue!

share|improve this answer
    
Don't ever do this without actually verifying that you want to trust that root certificate completely. If it's your own internal CA, then you definitely want to trust it - but these trust warnings exist to prevent you from trusting an attacker sitting between you and the server. –  Shane Madden May 25 '12 at 23:57
    
Thanks Shane! It was the clients own internal CA, which is why it was frustrating that the message kept popping up. They were thinking there was something wrong with the server setup. –  Hanny May 29 '12 at 13:03

I was getting the Security Alert while trying to set up Outlook to connect to my company's Exchange Server from a remote location.

As of this writing, when you choose to "View Certificate" from the Security Alert, all you can see is the web server certificate itself in the certification path tab, the root CA cert is not present. So no way to import the Root CA cert and importing the web server cert is useless, doesn't work, period.

In my case I had to go to a properly connected/configured computer in my Windows domain and export the root CA certificate from there. Once I had the Root CA cert, I imported it as many have suggested to the Trusted Root CA section in the certificate store of the problem computer. In both cases I used the MMC console, added the certificates snap-in, selecting computer and local computer.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.