Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I currently have a server that is running vSphere 5 (ESXi). My management interface (VMKernel) has an address of 173.198.215.78 and the gateway on that one is 173.198.215.78. It appears to be set up fine and I can manage the server over that IP.

The problem comes when I set up VMs on the same vSwitch. It's pretty much a default configuration. My host has given me a small block of IPs from another subnet and I'm trying to utilize them in my VM, with no luck:

IP 173.198.246.72 Netmask 255.255.255.255 Gateway 173.198.215.77

My host told me to set the gateway to 173.198.215.78. Is that correct? Either way, when I add those settings to my Windows Server 2008 VM, it cannot route out to the Internet.

If someone could point me towards where I am going wrong, I would really appreciate it.

share|improve this question
    
Are you sure the VMKernel gateway is configured to the VMKernel port address? That shouldn't work -- can you confirm those settings, and check what the netmask is set to? –  Shane Madden May 26 '12 at 0:47
    
That isn't a small block of IP's - it's a single IP. Can you confirm the netmask with your provider - specifically that it isn't 173.198.246.72 with a mask of 255.255.255.248? –  rnxrx May 26 '12 at 2:00
    
I'm sorry, I mistyped that. Thank you for catching it. The VMKernel IP is 173.198.215.78 and the gateway is .77. The netmask is 255.255.255.252. My block of IPs is 173.198.246.72-79. My provider says that they were added to the switchport my server is on. They told me to utilize netmask of 255.255.255.255. –  Adam May 26 '12 at 7:32
    
Is it a problem that my default gateway to the Internet is on a different subnet? –  Adam May 26 '12 at 7:39
    
255.255.255.252 is a /30, or 4 addresses (173.198.215.76/30), which would make sense if you vmkernel were .78 and the router was .77. My guess is that your mask actually should be a /29 (8 hosts), which is 255.255.255.248. I would confirm this, but if this is the case then you should try numbering your vhost at 173.198.215.73 with a mask of 255.255.255.248 and a gateway of 173.198.215.77. –  rnxrx May 27 '12 at 2:02
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.