Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I disabled dns recursion because of security alert of intodns.com by adding

options {
allow-recursion { localhost; };
};

now I set name server of my domain (ariafile.ir) on ns1.ariafile.ir and ns2.ariafile.ir

But no longer I can't use subdomain on ariafile.I enabled dns recursion and subdomains work correctly.

Is there any way to use subdomains on ariafile.ir with disabled dns recursion?

share|improve this question
1  
Is the subdomain hosted on the same nameserver? –  mgorven May 26 '12 at 5:33
    
Is this an external name server only, or are you also using it as the default name server for your client machines? –  Harry Johnston May 26 '12 at 23:19
    
yes,subdomain hosted on same name server and I didn't change default name server. –  Moein7tl May 27 '12 at 6:49
    
Is the problem affecting your client machines or machines on the internet? Or both? –  Harry Johnston May 28 '12 at 2:17

1 Answer 1

You probably forgot to delegate the subdomain in the parent domain's zone file:

parent.domain.   IN SOA   stuff

parent.domain.   IN NS    server1.
                 IN NS    server2.

other-records
[etc...]
foobar

; This is the part you might be missing
child.parent.domain.   IN NS    server1.    ; same servers
                       IN NS    servers.    ; as the parent domain

It happened to work when recursion was enabled but no longer with recursion off!

By the way, you should see if you can turn recursion completely off instead of just allowing it for localhost. You won't achieve all of the benefits unless you do this. Use a different nameserver recusrive resolution.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.