Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I followed the instructions here to install curl in my server but it is without open ssl. I did it through SSH, i got the root access. I restarted my apache after the installation but i can't get the curl working still.

I have read in some article that i have to uncomment this extension=php_extension=php_curl.dll in php.ini. I did is, i run this command:

nano /usr/local/lib/php.ini

It brought me to the php.ini file, and i remove ;

;extension=php_extension=php_curl.dll

Then, restarted apache. Curl is not loaded still.

When i run command: curl-config --version. It will return, libcurl 7.26.0.

I tried to run this command: --with-curl=/usr/local/curl . But, it says

-bash: --with-curl=/usr/local/curl: No such file or directory

What else do i need to do to get my curl working?

Server Info: PHP version 5.2.5 , Operating system : linux, Architecture : i686

OK here is what i got from phpinfo:
- System: Linux domainname.domainname.com 2.6.18-92.1.13.el5PAE #1 SMP Thu Sep 4 04:05:54 EDT 2008 i686
- Build Date: Oct 30 2008 15:51:11
- Server API: Apache 2.0 Handler
- Apache Version: Apache/2.0.63 (Unix) mod_ssl/2.0.63 OpenSSL/0.9.8b mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 PHP/5.2.5
- Virtual Server: Yes

Distro: Red Hat Enterprise Linux Server release 5.2 (Tikanga)

share|improve this question
    
I think your phpinfo() output is truncated. –  Tom H May 26 '12 at 12:34
    
Also it would helpful if you provide your distro and release version. –  Tom H May 26 '12 at 12:40
    
--with-curl=/usr/local/curl is not a command, its an option to the configure command –  Tom H May 26 '12 at 12:47
    
Hi, i have interactive mode enabled. I paste the code that you said but i dont see any output in it. I am noob on this matter. –  user1149244 May 26 '12 at 12:50
    
Where can i get that distro and release version? –  user1149244 May 26 '12 at 12:50
show 4 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.