Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I had to restore a trashed filesystem from backup, now its not loading a lot of modules

lsmod before: http://pastebin.com/MxEDZmqs

lsmod after: http://pastebin.com/BthWiVXL

It was a different server I'm taking a backup from, and had a different raid setup so I had to do update-initramfs and grub-update, so that might have something to do with it

The server I took a backup from is still running

How do I restore these modules? Preferably without a restart.

share|improve this question
add comment

1 Answer

up vote 3 down vote accepted

I think many of those modules would be loaded on demand, hence once you start the services on the restored server you should see more modules in use. However there are some modules for which you will need to install the relevant packages.

A quick way to sync the packages installed is to make an exported list of all the packages from the old machine like so;

$ dpkg --get-selections | cut -f1 > /tmp/package-list

and then install those packages on the other server using the steps explained in this tutorial

Regarding the differences in the modules lists; for example I see the module soundcore in one list but not the other, so try to query the module information on the restored server to check that is available when required like so;

# modinfo soundcore
filename:       /lib/modules/3.3.1-5.fc16.x86_64/kernel/sound/soundcore.ko
alias:          char-major-14-*
license:        GPL
author:         Alan Cox
description:    Core sound module
depends:        
intree:         Y
vermagic:       3.3.1-5.fc16.x86_64 SMP mod_unload 
parm:           preclaim_oss:int

Once you have a module filename, from the details above, you can see which package needs to be installed to provide it, for example the module fbcon;

$ modinfo fbcon
filename:       /lib/modules/2.6.32-38-generic/kernel/drivers/video/console/fbcon.ko
license:        GPL
srcversion:     65B645FD36D989F537E4715
depends:        bitblit,font,tileblit
vermagic:       2.6.32-38-generic SMP mod_unload modversions

is provided by the linux-image package;

$ dpkg -S /lib/modules/2.6.32-37-generic/kernel/drivers/video/console/fbcon.ko
linux-image-2.6.32-37-generic: /lib/modules/2.6.32-37-generic/kernel/drivers/video/console/fbcon.ko
share|improve this answer
    
Thank you tom, I think I fixed it. Here is exactly what I did, for future reference: 1. I ran modinfo sch_sfq, it gave me an error, I don't remember the exact wording but it couldn't open a modules file in /lib/modules/ 2. I ran sudo apt-get update && sudo apt-get upgrade -f, it told me that kernel updates were kept back 3. I ran sudo apt-get dist-upgrade, which downloaded the kernel updates The os started loading the modules then and modinfo was producing the correct output. –  Shoshomiga May 27 '12 at 17:51
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.