Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm in an institution with a local area network with multiple labs, all of which access the net through a common proxy, set up in the client browser/app manually, now in one of the labs, the following settings work without issues:

device="eth0"
nm_controled="yes"
hwaddr...
type="ethernet"
ipaddr=172.16.x.x
prefix=24
gateway=172.16.x.x.
defroute=yes

This lab has a switch that goes though another lab from where it goes to the main proxy room. in another lab where I'm trying to get things working but the same settings dont work.

I can ping machines with private IPs in the lab, I can also ssh between them, but I cant access ftp between them, but http does seem to work within the lab.

Now within the lab is a 48 port old hp switch, which the goes to a cisco switch that goes via fiber to another building (where things are ok) the to proxy room. The machines in this lab of concern can't access the net even with correct proxy and IP settings, even pinging the proxy doesnt always work, sometimes it works but the same settings a few minutes later did not even allow ping.

If we bypass the HP switch and connect one of the machines directly to the cisco, ping works great, we can even ping the original lab where things work, ssh works, http too, but not ftp, but still no internet no matter what for private IPs. public IPs connected to the HP switch work intermittently, but the same settings work flawlessly when the machine with the public ip is directly connected to the cisco (thats how I'm writing this). No network setting have been changed anywhere that I know of or know to check. what could be wrong?

share|improve this question
3  
There's no need to obfuscate or hide private-range IP addresses. We can't connect to them without knowing the public IP they're NAT'd through. –  Magellan May 26 '12 at 17:00
    
@Adrian sorry, i was being more of lazy than paranoid the bad machines have no internet so i could not ctrl-c ctrl-v. the ip looks like 172.16.6.45 anf mask 255.255.255.0 though i think the mask is open at a the proxy, but earlier changing the mask to 255.0.0.0 while going through the HP the bad lab machines could see the proxy, then they stopped for a no apparent reason,then they started working with 255.255.255.0 and then stopped and all that within the last six hours. when i got to the lab one of the "bad lab" machined briefly connected to the net, then stopped completely. what a day. –  user122508 May 26 '12 at 19:50

1 Answer 1

I think you answered your own question. Removing the HP switch allows everything to work. Putting the HP switch back breaks it. Start by testing the connection between the Cisco and HP switches and work your way back. We don't have enough information to debug the HP switch (L2? L3? model number? configuration?) but it seems like your issue is most likely there.

share|improve this answer
    
i just left the lab, i'l have to get back to you in the morning on the device specifics, its a new lab (to me), and im new to the equipment, but the cisco is a 2960 or there about, now there is something else my post may not have made obvious, when i connect a machine with a private ip through the cisco, it can see the proxy, and also see the machines in the old lab thats doing fine, but wont connect to the net through the proxy , so i did a test, –  user122508 May 26 '12 at 19:54
    
i ssh to the lab thats ok thru' the cisco bypassing the HP, to a machine that has a private ip and started a browser and guess what? it does not connect, but the thing is if i physically got to the good lab and access the net though the same box, the net is ok via the browser, and if i ssh again from the bad lab through the cisco bypassing the HP, to the good lab to a machine with a public ip and i start a browser the browser works fine, these two results have me stumped. ~ –  user122508 May 26 '12 at 19:56
    
the model is hp procurve switch 4104gl j4887a , –  user122508 May 27 '12 at 5:08
    
Check for vlans.. managed switches can have funky old settings lying around ;-) –  Grizly Oct 30 '12 at 4:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.