Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running into a funny little issue with Asterisk 10.3, but it seems to be applicable to 10.4 as well.

The server running Asterisk was relocated from a VPS to dedicated hardware, and now only 1 of several SIP peers can connect properly.

SIP peers are loaded from an ODBC connection into realtime. Given that 1 is able to connect without any issue, and functions as expected, runs the queries, and so on I've ruled any database connection issues out. The one client happens to be a Grandsteam ATA.

But that's where it stops. Nobody else can connect as Asterisk tells them 401 Unauthorized when they try to register.

The only variables that have changed in this equation may be the way the networks are setup. The old host was a VPS (Xen) and the new hardware is dedicated. In this case the server is sitting on a public IP. There shouldn't be any funky NAT trickery happening on the dedicated hardware, but mostly all connecting peers are behind a NAT of some kind.

What I've tried so far:

  • Adjusted nat=no on each peer, same result
  • Adjusted nat=no on each peer, insecure=invite,port, same result

To top it all off the Grandstream is connecting just fine. But other clients like CSipSimple, Cisco IP 79xx, Polycoms... no go.

Any idea what might need be changed to allow these peers to connect again?


    <--- SIP read from UDP: --->
    Via: SIP/2.0/UDP;rport;branch=z9hG4bKPjZ8cqUxWzs6KnfN5kqG9lrD-V0hXQNppc
    Route: <;lr>
    Max-Forwards: 70
    From: "Erik" <>;tag=uwgq3EEWaQ0DuPwWEzuLfVA3aajqyXL6
    To: "Erik" <>
    Call-ID: ohWlNbqWRdOme5TvFr3.r6mnPUbjoKqs
    CSeq: 1582 REGISTER
    User-Agent: CSipSimple r1108 / GT-S5830D-10
    Contact: "Erik" <sip:334@;ob>
    Expires: 900
    Content-Length: 0

    --- (13 headers 0 lines) ---
    Sending to (NAT)

    <--- Transmitting (NAT) to --->
    SIP/2.0 401 Unauthorized
    Via: SIP/2.0/UDP;branch=z9hG4bKPjZ8cqUxWzs6KnfN5kqG9lrD-V0hXQNppc;received=;rport=35286
    From: "Erik" <>;tag=uwgq3EEWaQ0DuPwWEzuLfVA3aajqyXL6
    To: "Erik" <>;tag=as2da10195
    Call-ID: ohWlNbqWRdOme5TvFr3.r6mnPUbjoKqs
    CSeq: 1582 REGISTER
    Server: Asterisk PBX 10.3.0
    Supported: replaces, timer
    WWW-Authenticate: Digest algorithm=MD5, realm="asterisk", nonce="7837df5c"
    Content-Length: 0

share|improve this question
Where is this bound address at? Which config file and where would it be located in the panel because I do not see this. Thanks, – user150482 Dec 20 '12 at 21:21
up vote 1 down vote accepted

Issue resolved! Despite Asterisk offering the ability to deal with more than one address by specifying as your listen address, the box on which Asterisk was present was sending invites from other aliased IPs on the server instead of the one intended. Binding Asterisk to one IP, and connecting to that one IP, resolves this issue entirely.

share|improve this answer
can you elaborate? should accept connections from any device, no? – Thufir Mar 24 '15 at 5:23

As this might helps for somebody:


helped me after a similar relocation. For me it was vm to vm but bridged to the exact same network so I just don't get it why my working configuration stopped to work. I experienced one way call effect. The calls from outside SIP PBX going into the asterisk then sent out to voip softclients were working but the voip softclients couldn't communicate at all.

share|improve this answer
What security implications does this have? – Andreas Mar 3 at 11:54

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.