Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am getting the error 503 when I try to start Jetty. Does anyone know what this might mean. I am running Jetty 7 and starting it with the start.jar file.

If anyone knows how to configure Jetty to work on Windows, that would be helpful. Thanks.

share|improve this question
    
What version of IIS/Windows are you using? –  Adam Brand Jul 11 '09 at 20:02
    
Windows VISTA - it's just for dev –  Ankur Jul 21 '09 at 16:37
add comment

2 Answers

up vote 1 down vote accepted

Check the log files to see if there is more useful information there. If you are not already running it from the command line, try that ("java -jar start.jar" instead of double-clicking the start.jar file). Between those two there should be information pointing you in the right direction.

Most likely what is happening is that there is a problem with the WAR file Jetty is trying to start. You will need to see a log file or other output to determine what problem it is having.

share|improve this answer
add comment

I was getting a 503 error when trying to get Jetty7 up and running on Windows. In my console, I had the following exception:

2009-08-11 14:39:50.150:WARN::Failed startup of context WebAppContext@66e815@66e815/,file:/C:/Documents and Settings/user/Local Settings/Temp/Jetty_0_0_0_0_8080_test.war.hcx133/webinf/;jar:file:/C:/tools/jetty7/jetty-distribution-7.0.0.RC3/webapps/test.war!/;,C:\tools\jetty7\jetty-distribution-7.0.0.RC3/webapps/test.war
java.lang.RuntimeException: java.net.URISyntaxException: Illegal character in path at index 18: file:/C:/Documents and Settings/user/Local Settings/Temp/Jetty_0_0_0_0_8080_test.war____.hcx133/webinf/WEB-INF/lib/jetty-client-7.0.0.RC3.jar
        at org.eclipse.jetty.util.resource.Resource.getURI(Resource.java:359)
        at org.eclipse.jetty.webapp.WebInfConfiguration.preConfigure(WebInfConfiguration.java:105)
        at org.eclipse.jetty.webapp.WebAppContext.doStart(WebAppContext.java:338)

Jetty must use the temp dir as a staging area for apps, and does not like a path that contains whitespace. I worked around this by altering the java.io.tmpdir system property at jvm start:

java -Djava.io.tmpdir=C:\temp -jar start.jar
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.