Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've set suhosin.perdir = 'p' in my ini file. I would now like to change suhosin ini settings on a per-folder basis.

The following all work (running phpinfo() inside the desired folder shows the changed values):

php_value suhosin.post.max_array_depth 100
php_value suhosin.post.max_array_index_length 128
php_value suhosin.post.max_name_length 128
php_value suhosin.post.max_value_length 2000000
php_value suhosin.post.max_totalname_length 512
php_value suhosin.post.max_vars 1000

But when I also add the .request settings (which I understand are an upper limit for the .post settings), they do not change:

php_value suhosin.request.max_array_depth 100
php_value suhosin.request.max_array_index_length 128
php_value suhosin.request.max_name_length 128
php_value suhosin.request.max_value_length  2000000
php_value suhosin.request.max_totalname_length 512
php_value suhosin.request.max_vars 1000

https://lh4.googleusercontent.com/-Hq6kIKiFvTM/T8NgzIZUafI/AAAAAAAAADY/EPKx_bJ9YLg/s400/1338204362948.png

Do you have any idea if there is anything else I have to check/setup? Am I forgetting someting?

Thank you! Matei

share|improve this question

1 Answer 1

up vote 0 down vote accepted

You'll need to set suhosin.perdir = 'pr' for it to read both request and post values from an .htaccess file I think.. Don't have anything to test this on currently though.

share|improve this answer
    
Great. It worked! Thank you. –  mitai May 29 '12 at 7:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.