Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My company uses Mac and they have a lot of filenames with #. I noticed that using an external NAS (not Apple, but Synology or Qnap), the 'search' failed when it meet file with # in a file name. Is this a limit of the AFP open source protocol version or some other reason?

share|improve this question
up vote 1 down vote accepted

I cannot speak for open source implementations of AFP, but Apple's implementation seems to have no trouble with it, either for file transfers or for searches. I just tried it with an OS X 10.7 (Lion) client and both 10.7 and 10.7 Servers, and everything worked as expected.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.