Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I was using PostgreSQL 8.4. I tried removing it through Synaptic Manager and then I tried to install 9.1, but I still version 8.4. I deleted all the files associated with postgresql. Now I am unable to install any version of PostgreSQL. When I try I get this error:

Setting up postgresql-9.1 (9.1.3-1~lucid) ...
.: 12: Can't open /usr/share/postgresql-common/maintscripts-functions
dpkg: error processing postgresql-9.1 (--configure):
 subprocess installed post-installation script returned error exit status 2
dpkg: dependency problems prevent configuration of postgresql:
 postgresql depends on postgresql-9.1; however:
  Package postgresql-9.1 is not configured yet.
dpkg: error processing postgresql (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          Errors were encountered while processing:
 postgresql-9.1
 postgresql
E: Sub-process /usr/bin/dpkg returned an error code (1)

Please tell me the way to remove postgres completely so I can install a fresh version.

share

migration rejected from stackoverflow.com Jul 10 '13 at 15:11

This question came from our site for professional and enthusiast programmers. Votes, comments, and answers are locked due to the question being closed here, but it may be eligible for editing and reopening on the site where it originated.

closed as unclear what you're asking by Jenny D, Falcon Momot, mdpc, Jacob, Scott Pack Jul 10 '13 at 15:11

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Downvoted: lacks important info like OS and version, commands run to get to this point, what exactly was deleted, etc. Question specific to one broken configuration, and more of a sysadmin qn anyway. Incoherent and incomplete. –  Craig Ringer May 26 '12 at 1:44
    
This question appears to be off-topic because it is about package management on linux, unrelated to sysadmin tasks, and belongs on unix.stackexhange.com instead. –  Jenny D Jul 9 '13 at 6:06
comments disabled on deleted / locked posts