Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have a web application which uses an SQLite database, normally this is accessed by giving the IIS user permissions to write to the database folder and works correctly.

But when setting up the site in a Virtual Directory instead of a Web Site, the application fails when attempting to connect to the database file. I can only assume this is due permissions somehow not applying or being different on the database folder, as the same error can occur if permissions are not change when doing a standard Web Site install.

The reason for setting up the web app as a Virtual Directory is due to a client request so they could use the hostnameofserver/virtualsite to access, allowing them to run multiple sites on a single server without needing to change any local DNS server settings etc.

The client server, and the server I am testing on is a Server 2003 R2 SP2 (32bit).

Thanks

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

For anyone else having this issue, it was not to do with permissions at all, but rather the path being referenced.

The application was going for /database which seems to have been taking it back to the root directory of the Web Site, not the virtual directory. So this can be solved by not using /database or ~/database and using a full path or just database.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.