Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a Rails application running on CentOS with Apache/Passenger, and I have a little problem: I don't have any logs for my Rails Application, What am I missing?

This is my apache conf :

<VirtualHost *:80>
    Include /home/ftpanel/conf/alias/
    DocumentRoot /home/mgimmo/public_html/immo/public/

    #Configuration PHP
FastCgiExternalServer /home/mgimmo/ftpanel-config/php5.fpm -socket   /home/ftpanel/conf/sock/mgimmo.sock
    Alias /ftpanel-config/ /home/mgimmo/ftpanel-config/

    <Directory /home/mgimmo/public_html/immo/public/>
            Options -Indexes FollowSymLinks -MultiViews
            AllowOverride All
    ServerSignature Off

share|improve this question
Your log should be /home/mgimmo/public_html/immo/log/production.log. Check if that is writeable by the web server user. – taro May 29 '12 at 19:24
I make a chown on the production.log and yeah it's work ! Why I didn't think that soon ... Can you make an answer then I give u some points :) – Awea May 30 '12 at 14:20

1 Answer 1

Application logs are as usual in log directory under application's root.

In your case, full path is /home/mgimmo/public_html/immo/log/production.log

Make sure that file is writable by web server user.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.