Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a VPS with Centos 5.8

In phpinfo displays: './configure' '--disable-fileinfo' '--disable-pdo' '--enable-bcmath' '--enable-calendar' '--enable-ftp' '--enable-libxml' '--enable-magic-quotes' '--enable-sockets' '--prefix=/usr/local' '--with-apxs2=/usr/local/apache/bin/apxs' '--with-curl=/opt/curlssl/' '--with-imap=/opt/php_with_imap_client/' '--with-imap-ssl=/usr' '--with-kerberos' '--with-libdir=lib64' '--with-libxml-dir=/opt/xml2/' '--with-mysql=/usr' '--with-mysql-sock=/var/lib/mysql/mysql.sock' '--with-openssl=/usr' '--with-openssl-dir=/usr' '--with-pcre-regex=/opt/pcre' '--with-pic' '--with-zlib' '--with-zlib-dir=/usr'

I've tried this:

http://www.host1free.com/forum/vps-technical-support/7248-tutoria-centos-apache-webserver-mysql-php-eaccelerator-apc.html

And aparently it installed php-pdo

# rpm -qa |grep php
php-5.3.13-1.el5.remi
php-xml-5.3.13-1.el5.remi
php-common-5.3.13-1.el5.remi
php-cli-5.3.13-1.el5.remi
php-pdo-5.3.13-1.el5.remi
php-xmlrpc-5.3.13-1.el5.remi
php-mcrypt-5.3.13-1.el5.remi

But I've restarted apache and it still says in my phpinfo: '--disable-pdo'

Should I rebuild php? Do I need to do some other step?

share|improve this question

1 Answer 1

Installing additional extensions does not change the options PHP was compiled with. Verify that the pdo_mysql extension is installed via php -m or phpinfo().

share|improve this answer
    
This is the result # php -m [PHP Modules] bcmath calendar Core ctype curl date dom ereg filter ftp hash iconv imap json libxml mysql openssl pcre Phar posix Reflection session SimpleXML sockets SPL SQLite sqlite3 standard timezonedb tokenizer xml xmlreader xmlwriter zlib –  nacho3d May 30 '12 at 4:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.