Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a virtual host:

   DocumentRoot "D:/docs"

no when i try to access virtual host, i get 403 error:

Access forbidden!
You don't have permission to access the requested directory. There is either no index document or the directory is read-protected.

Apache is installed in D:/apache
while virtual host is in D:/docs

share|improve this question

403 access forbidden means just that. Check that the apache process has permission to read and traverse the underlying filesystem d:/docs. If it doesn't then make it so.

share|improve this answer
I found the solution – Omid Amraei May 30 '12 at 8:40

Add this under DocumentRoot:

Options FollowSymLinks

What is FollowSymLinks?

Symbolic links (also called symlinks or softlinks) most resemble Windows shortcuts. Websites are often set up in a way that they show pictures and other content as being physically located at some other location than they really are.


share|improve this answer
Not completely solved the problem – Omid Amraei May 30 '12 at 8:40
up vote 0 down vote accepted

Problem solved with adding

<Directory D:/docs>
  Options Indexes +FollowSymLinks Includes ExecCGI
  AllowOverride All
  Order allow,deny
  Allow from all
share|improve this answer
this did not work for me – MightyPork Apr 29 '15 at 6:49
@MightyPork try set the folder permission chmod 775 – Omid Amraei Apr 30 '15 at 6:28

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.