Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a virtual host:

Listen 192.168.0.1:2020
NameVirtualHost 192.168.0.1:2020
<VirtualHost 192.168.0.1:2020>
   DocumentRoot "D:/docs"
</VirtualHost>

no when i try to access virtual host, i get 403 error:

Access forbidden!
You don't have permission to access the requested directory. There is either no index document or the directory is read-protected.

Edit
Apache is installed in D:/apache
while virtual host is in D:/docs

share|improve this question

3 Answers 3

403 access forbidden means just that. Check that the apache process has permission to read and traverse the underlying filesystem d:/docs. If it doesn't then make it so.

share|improve this answer
    
I found the solution –  Omid Amraei May 30 '12 at 8:40

Add this under DocumentRoot:

Options FollowSymLinks

What is FollowSymLinks?

Symbolic links (also called symlinks or softlinks) most resemble Windows shortcuts. Websites are often set up in a way that they show pictures and other content as being physically located at some other location than they really are.

source: http://www.maxi-pedia.com/FollowSymLinks

share|improve this answer
    
Not completely solved the problem –  Omid Amraei May 30 '12 at 8:40
up vote 0 down vote accepted

Problem solved with adding

<Directory D:/docs>
  Options Indexes +FollowSymLinks Includes ExecCGI
  AllowOverride All
  Order allow,deny
  Allow from all
</Directory>
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.