Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Environment:

Windows 2008 Server Edition

Netbeans 6.7.1

Glassfish 2.1

Apache 2.2.15 for win32

Original problem (almost fixed):

The HTTP/1.1 GET method to send data fails if I wait for more than 30 seconds.

What I did:

I added to the http.conf file of Apache these lines:

#
# Timeout: The number of seconds before receives and sends time out.
#
Timeout 9000

#
# KeepAlive: Whether or not to allow persistent connections (more than
# one request per connection). Set to "Off" to deactivate.
#
KeepAlive On

I went to the Glassfish panel (localhost:4848) and in Configuration > HTTP services and I put:

Timeout request: 9000 seconds (it was 30)

Standby time: -1 (it was 30 seconds)

Problem:

I am not able to put for glassfish a timeout bigger than 2 minutes to send a GET method.

I found this article about glassfish settings, but i'm not able to find WHERE I should put those parameters, and if they could work.

Can anybody help try to set this timeout to a higher limit? Maybe it's even a different setting?

New tried solution:

I went to the glassfish panel control, and to Configuration > Subprocesses > "Thread-pool-name" and changed the idle timeout from 120 seconds to 1200 seconds. Then I restarted the glassfish service (both from the administrative tools and from asadmin), but still it waits 120 seconds to go idle. I even tried restarting the whole server, still no results. Maybe some setting in postgres? Or the connection of netbeans to postgres through glassfish?

New finding:

I've been searching on the internet and maybe it could be a proxy timeout, but i don't really now how to change it: can anybody help me please?

share|improve this question
add comment

1 Answer 1

in the end it was the ProxyTimeout directive in the httpd.conf file of Apache.

http://httpd.apache.org/docs/2.0/mod/mod_proxy.html#proxytimeout

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.