Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I can access my host like this…


but can't use periods…

here's my virtual host directive…

<VirtualHost *:80>
    ServerName keggyshop
    DocumentRoot "~/sites/2012/keggy/web/pages/keggy/120528/sandbox/public"

    <Directory "~/sites/2012/keggy/web/pages/keggy/120528/sandbox/public">
            Options Includes FollowSymLinks
            AllowOverride All
            Order allow,deny
    Allow from all



host file    keggyshop

traceroute for keggyshop…

user$ traceroute keggyshop
traceroute to keggyshop (, 64 hops max, 52 byte packets
1  keggyshop (  1.188 ms  0.683 ms  0.747 ms

traceroute for…

user$ traceroute
traceroute: Warning: has multiple addresses; using
traceroute to (, 64 hops max, 52 byte packets
1  * (  0.856 ms  0.568 ms
2 (  15.232 ms  7.002 ms  7.936 ms
3 (  7.962 ms  7.813 ms  7.712 ms
4 (  10.999 ms  14.001 ms  15.466 ms
5 (  11.231 ms  17.321 ms  12.745 ms
6 (  13.972 ms  11.704 ms  16.477 ms
7 (  9.237 ms  11.896 ms (  7.481 ms
8 (  16.682 ms  11.791 ms  11.981 ms
9 (  12.977 ms  15.706 ms  9.709 ms
10 (  30.473 ms  30.497 ms  31.750 ms
11 (  36.699 ms  50.785 ms  35.957 ms
12 (  34.723 ms  31.118 ms  29.967 ms
13 (  30.471 ms (  33.392 ms  35.210 ms
14 (  32.453 ms (  32.020 ms (  32.417 ms
15 (  31.274 ms  34.854 ms  30.194 ms
share|improve this question

closed as off topic by John Gardeniers, Iain May 31 '12 at 22:02

Questions on Server Fault are expected to relate to server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

your examples don't match your virtual host directive, can you be more clear about what doesn't work, and where from, and what errors or messages you get. – EightBitTony May 30 '12 at 19:19
updated. i removed the server alias. so i changed my server name to still not working – punchfacechamp May 30 '12 at 21:27
Is actually a resolvable hostname on your computer? Is there a DNS or host file entry to turn it into an IP address? – EightBitTony May 30 '12 at 22:26
It's also good practice not to use a name that could resolve into a valid DNS name, so using .edu as a suffix is a bad idea. – Sven May 30 '12 at 22:46
ok, i've changed the hostname to '.dev' and included the host file above. still no go – punchfacechamp May 30 '12 at 23:16

2 Answers 2

You need to be careful when using periods (dots) in DNS names. The period has special meaning and it should not be handled like any othher character.

Anyway, you need to make sure the name you are using is resolvable by your clients (preferably via DNS server). You can use hosts file for testing purposes and in your local environment. Then, you can verify your web server config to match specific name(s).

share|improve this answer
this is for my development environment. i removed all other virtual hosts and removed the server alias. so now my server name is and it still doesn't work – punchfacechamp May 30 '12 at 21:26
@punchfacechamp: Can you ping this name? – Khaled May 31 '12 at 7:08
yes, for some reason resolves to which is a public ip i've never seen. isn't a valid location – punchfacechamp May 31 '12 at 15:39
see the traceroute i added above – punchfacechamp May 31 '12 at 16:07
SOLVED - host file was corrupt. created a new one from scratch and it worked. perhaps it was because i edited the host file with textmate? anyway, thanks to all who contributed! – punchfacechamp May 31 '12 at 18:02

Your problem is that you don't understand.

More specifically with the .dev resolving to something other that you have a name resolution problem, not a vhost problem.

You will need to find out why the is resolving to multiple addresses and fix it so that it only resolves to

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.