Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am having some troubles with a dedicated server, some of the domains in it are suddenly redirecting to the www. version of the domain, but there's no htaccess file or config in http.conf or /etc/nginx/vhosts/domain.

The "redirect" is not even a 301 or 302, I am not sure what it is but the sniffer shows all the fields empty for the domain.com request and then goes right ahead to open www.domain.com where it received the server response.

What else could I check to find what's causing this?

share|improve this question
1  
What do you mean by "shows all the fields empty"? Does the server respond to the HTTP request? –  Shane Madden May 30 '12 at 23:52
    
@ShaneMadden this is what i see in the sniffer: i.imgur.com/bonuz.png there's no response on domain.com, it goes automatically to www.domain.com and there's where it gets the 200 OK response. –  usjes May 31 '12 at 0:07
    
Then.. the DNS name of domain.com resolves to a different address than www.domain.com, right? –  Shane Madden May 31 '12 at 0:20
    
@ShaneMadden No, they both have the same nameservers, ns1.domain.com and ns2.domain.com which points to the server ip. dig domain.com and dig www.domain.com show the same nameservers, the only difference is that www.domain.com shows a CNAME entry. –  usjes May 31 '12 at 0:33
    
What's the data in the CNAME entry? Is it pointing to domain.com, or something else? –  Shane Madden May 31 '12 at 0:38
show 4 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.