Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Continue from this topic, I'm stopping at step 4:

cloudify@default> install-application --verbose -timeout 10 /usr/local/src/gigaspaces-cloudify-2.1.0-ga/recipes/apps/petclinic-simple
Validating file petclinic-simple
Uploading application petclinic
Application [petclinic] with 2 services
Service [mongod] 1 planned instances
Service [tomcat] depends on [mongod] 1 planned instances
Deploying mongod with 1 planned instances.
Deploying tomcat with 1 planned instances.
.....Operation failed. java.util.concurrent.TimeoutException: Application installation timed out
    at org.cloudifysource.shell.ConditionLatch.waitFor(ConditionLatch.java:146)
    at org.cloudifysource.shell.rest.RestLifecycleEventsLatch.waitForLifecycleEvents(RestLifecycleEventsLatch.java:79)
    at org.cloudifysource.shell.rest.RestAdminFacade.waitForLifecycleEvents(RestAdminFacade.java:275)
    at org.cloudifysource.shell.commands.InstallApplication.doExecute(InstallApplication.java:112)
    at org.cloudifysource.shell.commands.AbstractGSCommand.execute(AbstractGSCommand.java:83)
    at org.cloudifysource.shell.commands.AdminAwareCommand.execute(AdminAwareCommand.java:36)
    at org.apache.felix.gogo.commands.basic.AbstractCommand.execute(AbstractCommand.java:35)
    at org.apache.felix.gogo.runtime.Closure.executeCmd(Closure.java:474)
    at org.apache.felix.gogo.runtime.Closure.executeStatement(Closure.java:400)
    at org.apache.felix.gogo.runtime.Pipe.run(Pipe.java:108)
    at org.apache.felix.gogo.runtime.Closure.execute(Closure.java:183)
    at org.apache.felix.gogo.runtime.Closure.execute(Closure.java:120)
    at org.apache.felix.gogo.runtime.CommandSessionImpl.execute(CommandSessionImpl.java:89)
    at org.apache.karaf.shell.console.jline.Console.run(Console.java:221)
    at org.apache.karaf.shell.console.Main.run(Main.java:191)
    at org.apache.karaf.shell.console.Main.run(Main.java:89)
    at org.cloudifysource.shell.GigaShellMain.main(GigaShellMain.java:122)

Operation failed. 

The log file doesn't include any further info than what it displayed on the Cloudify shell. I also tried to deploy the travel app but got the same error.

How to increase the debug level?

share|improve this question
1  
In order to investigate this further, we would need all system logs. Please login to localhost:8099 (the webui console). Click the "Services" tab. Then find 127.0.0.1 and click the small down arrow icon right next to it. Click "Generate Dump". The resulting zip file includes all logs. I opened a JIRA issue where you can attach this zip file at cloudifysource.atlassian.net/browse/CLOUDIFY-844 –  Itai Frenkel May 31 '12 at 9:30
    
@ItaiFrenkel: I've attached the zip file as you required. I'm looking forward to hearing from you. –  quanta May 31 '12 at 10:56
1  
let's continue the investigation in JIRA. I have a few questions about the logs. We'll report the results here later. –  Itai Frenkel May 31 '12 at 12:40
1  
The reason for this error was probably the fact that gs-agent.sh was manually started from commandline when you were debugging serverfault.com/questions/393898/… –  Itai Frenkel Jun 2 '12 at 5:54
add comment

1 Answer

Have you tried increasing the timeout? The stack trace seems to indicate that it hit a timeout and you are supplying one on the command line. If they are the same timeout, that may do it. Of course, it's possible that whatever it's waiting for will never return.

The rest.RestAdminFacade further down the stack trace seems to indicate that it's making network requests and waiting on the response when it times out. Standard network debugging applies here. Try a tcpdump and check your DNS requests and HTTP requests.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.