Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I updated MySQL with yum.

And it doesn't start now.

I try find / | grep mysql.sock.

I can't see any sock file.

How can I create it? Or any possible solution?

Thanks.

share|improve this question

migrated from stackoverflow.com May 31 '12 at 8:37

This question came from our site for professional and enthusiast programmers.

2  
mysql.sock file creates when server is started –  GhKaren May 31 '12 at 7:18
    
i can't start the service –  Kronokrator May 31 '12 at 7:19
    
what kind of error you get when starting mysql server? –  GhKaren May 31 '12 at 7:21
4  
You have two problems: 1. You have a skip-bdb option in your config somewhere, which is no longer valid for current MySQL. 2. You have a skip-innodb option in your config as well which is disabling MySQL's only good storage engine. –  duskwuff May 31 '12 at 7:24
1  
@Kronokrator Adding the log to your question instead of a comment would make it much more readable. –  glglgl May 31 '12 at 8:06

1 Answer 1

up vote 0 down vote accepted

It sounds like mysqld isn't running at all. Be sure to remove the invalid/old options from /etc/my.cnf and then check in the log that mysqld starts correctly.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.