Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running a backported KVM on a Debian Squeeze. ATM the KVM-Guest can't connect to the internet through the bridge I have set up. The guests can reach each other, the host but nothing outside. I can neither ping, nslookup or do anything to a remote address. The guest are configured to have a static IP. When I didn;t have the bridge but a virtual bridge (the KVM-default) the guest could connect fine. After setting up the bridge things broke, so I think the problem lies there.

# The loopback network interface
auto lo br0
iface lo inet loopback

# Bonding Interface
auto bond0
iface bond0 inet static
address 10.XXX.XXX.84
network 10.XXX.XXX.64
gateway 10.XXX.XXX.65
slaves eth0 eth1
bond_mode active-backup
bond_miimon 100
bond_downdelay 200
bond_updelay 200

iface br0 inet static
    bridge_ports eth0 eth1
    bridge_stp on
    bridge_maxwait 0

Thanks in advance for your help !

share|improve this question

1.) You're putting eth0 and eth1 into a bonding group and you're bridging them into br0 - you can't do both. Have you tried putting bond0 in instead?

2.) Also - why do you have STP on? Unless you're trying to bridge external segments together in a redundant topology or are you trying to connect a bonded interface to your VM's? Turn it off unless you need it.

share|improve this answer
Hi, thanks for your answer. I tried putting bond0, but with no luck. But I removed the stp, don't know why it was there ^^ – cete3 Jun 1 '12 at 9:59
Confirm that the interfaces are actually up and operational (i.e. receiving / sending frames) - both from ifconfig and with tcpdump. I've seen a number of cases where Debian/Ubuntu will correctly configure some of these bridged interfaces but not actually bring them up. – rnxrx Jun 1 '12 at 20:45
In ifconfig I see the interfaces up and I also see traffic with tcpdump (e.g ssh traffic). Plus, it's a remote server, so if it wasn't up I couldn't connect to it :) – cete3 Jun 2 '12 at 17:05
up vote 0 down vote accepted

Ok, silly me - as it turns out the problem was that the interface and the gateway had the same IP.

share|improve this answer

Another possibility:

Make sure the host's iptables aren't getting in the way of the guests!

share|improve this answer
This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. – Khaled Jan 11 '13 at 2:19

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.