Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So today I was trying to install a fresh instance of Magento v1.7.0 on my vps which is running nginx. Once I uploaded the clean install to public_html I unzipped it and entered my ip to run the install i.e. Initially I got a "SSL connection error" in chrome, so I then tried this then worked and redirected me to the magento install page but I noticed the style was broken so I went to view the source and found that every link had https:// before it. Example:

<link rel="stylesheet" href="" type="text/css"   media="all" />
<link rel="stylesheet" href="" type="text/css" media="all" />
<link rel="stylesheet" href="" type="text/css" media="all" />

I then had a look around the default .htaccess file to see if there where any rewrites but didn't notice any.

My current Nginx config:

Note: This is happening before I have even installed magento

Any ideas what could be causing this issue?


share|improve this question

This question belongs on the magento forums... (for best results). The contents of the magento distribution are beyond what most of us can help with.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.