Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When i try to install fastcgi in ubuntu server 12.04 I get the following error:

sudo apt-get install libapache2-mod-fastcgi


Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package libapache2-mod-fastcgi is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libapache2-mod-fastcgi' has no installation candidate

Any solution?

share|improve this question

3 Answers 3

up vote 9 down vote accepted

libapache2-mod-fastcgi can be found in multiverse. If I remember correctly, a default installation of Ubuntu used not to enable multiverse (but should nowadays).

Maybe its disabled on your system and you'll have to add it to the list of repositories (as easy as editing /etc/apt/sources.list and appending multiverse after main or using the graphical packet manager).

Debian ships libapache2-mod-fastcgi as part of non-free by the way, so that's probably a licence issue.

share|improve this answer
    
The multiverse respository was not enabled. Thanks. –  brpaz Jun 7 '12 at 13:23
    
after you append multiverse to the file you need to run apt-get update then it all worked fine for me. –  simbo1905 Apr 18 at 19:11

This package can be found in ubuntu 12.04 packages as shown here. You may have invalid apt sources. Did you do any changes to your sources?

You can also try to run:

$ sudo apt-get update
$ sudo apt-get upgrade

to update your packages list and upgrade the packages that need to be upgraded.

share|improve this answer
    
agreed, must be your repository that is setup wrongfully. make sure that in sources.list, you only have 'precise' for the ubuntu deb entries or you may run into package dependency problems in regards to version numbers –  mschr Jun 3 '12 at 15:34

If you cannot run a proper update/upgrade, try issuing following

sudo apt-get check

and if there are found 'broken dependencies', run what khaled said with -f parameter added, like so:

sudo apt-get -f update
sudo apt-get -f upgrade
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.