Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a PC with recently installed Gigabyte GA-X79-UD5 MB. I've encountered some weird problem with getting SMART data or temperature for HDDs. Every single tool I've tried in Windows 7 just can't get any data (HDTune, AIDA64...). I was suspecting that SMART feature is disabled in BIOS but it's seems like there is no such option in BIOS settings. I've even tried to update BIOS but still no luck.

Same issue with both controllers on that MB (Intel and Marvell). It seems unlikely that both controllers end up with exact same issue. Both controllers are working in AHCI mode.

Is there anythig that can interfere with getting SMART ant temp data from HDDs? Or is there any way to check that it's actuall MB issue?

Is it even possible that it is hardware issue since all HDDs seems to work normal despite the fact that I can't get any temperature or SMART data from it.

share|improve this question

2 Answers 2

You may want to check if the WMI class exist and that you can retrieve the WMI data for the drives. If not, that may be a good place to start. You can use a tool such as Microsoft WMI Code Creator, and browse/display WMI information. Select the root\WMI namespace, and the MSStorageDriver_ATAPISmartData class. Select all of the properties, and click Execute Code.

enter image description here

Microsoft WMI Code Creator download:

share|improve this answer
up vote 2 down vote accepted

I've found a reason of such strange behaviour and it's an obvious bug in Intel RSTe driver. Actually I'm not the first one who found out that.

I've found some discussions of the matter on Intel and AIDA64 forums: Intel Forum, AIDA64 Forum

The thing is that Intel RSTe driver is "stuck" in RAID no matter of real MB settings and it's result in issues with SMART and temperature reading as well as BSODs from time to time. Right now I'm using standart Microsoft AHCI driver and waiting an answer from Intel support.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.