Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am getting a new server as I've messed up my current box, while trying to install Postgres 9 (on my CentOS 5.8 box). To cut a long story short, I removed postgres but yum decided to remove virtualmin-base as well, which broke my virtualmin install (postfix/dovcot stopped working). Virtualmin advise a fresh install once virtualmin-base has been removed/reinstalled.

So I'll probably make a decision based on this simple criteria: which distro out of the two makes it easiest for installing the latest versions of Ruby and Postgres?

They are both equally respected as web servers, so I really don't mind either way - I just want to use the one that will work best with the software I need.

share|improve this question

closed as primarily opinion-based by kce, dawud, mdpc, Tim Brigham, Falcon Momot Aug 14 '13 at 3:37

Many good questions generate some degree of opinion based on expert experience, but answers to this question will tend to be almost entirely based on opinions, rather than facts, references, or specific expertise.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Just want to add that I have googled and it appears easier for Debian - but I just want to double check. –  A4J Jun 3 '12 at 21:53

4 Answers 4

Well, from what I know, it might be easier for Debian, because you can try hooking into repositories made for Ubuntu and its forks.

My experiences with CentOS so far were rather horrible (of the "just compile custom locally already" variety).

share|improve this answer
1  
Debian has something called 'backports' which allows you to use more up-to-date packages (at the cost of possible security issues) –  A4J Jun 3 '12 at 22:02
    
@A4J That's what I have used in the past, and what would essentially be the solution here. It's just a matter of selecting the repositories and priorities :) –  p_l Jun 3 '12 at 22:05

From a Ruby perspective, I think RHEL/Scientific Linux/CentOS are still running Ruby 1.8.7.

I believe the Rails guys are slowly phasing out support for this version.

I know you can pull in a later version of Ruby from the Debian Testing/Unstable using pinning (YMMV - risky).

I don't know the requirements of your usage though.

share|improve this answer
    
Thanks, I will look into pinning. –  A4J Jun 4 '12 at 11:51

Ruby applications are usually dependent on a specific ruby version, so you better find out what ruby version you need and then take a look at what versions are in the standard repositories.

Ruby can be very picky. If the distro supports the ruby version you need then go for it. Having said that I use Centos with a self compiled version of Ruby and some Gems that didn't come with the repository.

If you go for Centos, the EPEL repository have some usually needed Gems.

share|improve this answer
    
I will want to use the latest Ruby version (currently 1.9.3). I have set up a Vagrant Debian box and managed to install rbenv on it successfully (wasn't able to on my Cent box). Later I am going to try and install postgres 9.1, and then downgrade PHP to 5.2. I can't think of anything else I might need. Not sure which Gems will be affected - do you have any examples? –  A4J Jun 4 '12 at 11:50
    
It depends on the application you are going to run on top of ruby. –  drcelus Jun 4 '12 at 12:47
    
They will be Rails (3.2.5) websites. I can't see it being a problem tbh :/ –  A4J Jun 4 '12 at 14:44

If you want to use the packages in the distro repositories instead of compiling from source:

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.