Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When I start my mysql it gives the following error on the log file. My default engine is MyIsam and I am using Innodb for a set of DB s only.

120604 12:24:49 mysqld_safe mysqld from pid file /var/lib/mysql/mysql1.pid1 ended
120604 12:24:58 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql
120604 12:24:58 [ERROR] InnoDB: syntax error in innodb_data_file_path
120604 12:24:58 [ERROR] Plugin 'InnoDB' init function returned error.
120604 12:24:58 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
120604 12:24:58 [Note] Event Scheduler: Loaded 0 events
120604 12:24:58 [Note] /usr/sbin/mysqld: ready for connections.
Version: '5.1.35-community-log'  socket: '/var/lib/mysql/mysql.sock1'  port: 3306  MySQL Community Server (GPL)

the below is InnoDB table and it gives the Unknown table engine 'InnoDB' error ?

mysql (mydb) > show create table sitemap;
ERROR 1286 (42000): Unknown table engine 'InnoDB'

My my.cnf is:

[mysqld]
socket = /var/lib/mysql/mysql.sock1
port = <port>
bind-address = <ip>
pid-file = /var/lib/mysql/mysql1.pid1
datadir = /var/lib/mysql
user = mysql
log-error = /var/lib/mysql/err.log
log-bin=Master-mysql-bin
server-id       = 1
ft_min_word_len = 2
skip-show-database
innodb_data_home_dir = /var/lib/mysql
innodb_data_file_path=ibdata1:194.19922M:autoextend
share|improve this question

2 Answers 2

I did not see this error before, but I can that from the error log:

120604 12:24:58 [ERROR] InnoDB: syntax error in innodb_data_file_path
120604 12:24:58 [ERROR] Plugin 'InnoDB' init function returned error.
120604 12:24:58 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.

It should be clear that you have a problem in your configuration specifically in innodb_data_file_path value. You can try to comment it and restart mysql. If it was successful, you can try to find a proper value for this option.

share|improve this answer

In your my.cnf I see the following:

innodb_data_file_path=ibdata1:194.19922M:autoextend

You have a decimal point in the number : 194.19922

Please round it to 194 and change it to

innodb_data_file_path=ibdata1:194M:autoextend

and restart mysql

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.