Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

if I try to install mysql-workbench-gpl on debian squeeze I get to following error message (it's complaining about unresolved dependencies):

Probieren Sie »apt-get -f install«, um dies zu korrigieren:
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 mysql-workbench-gpl : Hängt ab von: libatkmm-1.6-1 (>= 2.22.1) ist aber nicht installierbar
                       Hängt ab von: libcairomm-1.0-1 (>= 1.6.4) soll aber nicht installiert werden
                       Hängt ab von: libctemplate0 soll aber nicht installiert werden
                       Hängt ab von: libgdk-pixbuf2.0-0 (>= 2.22.0) ist aber nicht installierbar
                       Hängt ab von: libglibmm-2.4-1c2a (>= 2.28.0) soll aber nicht installiert werden
                       Hängt ab von: libgnome-keyring0 (>= 2.22.2) soll aber nicht installiert werden
                       Hängt ab von: libgtk2.0-0 (>= 2.22.0) aber 2.20.1-2 soll installiert werden
                       Hängt ab von: libgtkmm-2.4-1c2a (>= 1:2.24.0) soll aber nicht installiert werden
                       Hängt ab von: liblua5.1-0 soll aber nicht installiert werden
                       Hängt ab von: libpangomm-1.4-1 (>= 2.27.1) soll aber nicht installiert werden
                       Hängt ab von: libpcre3 (>= 8.10) aber 8.02-1.1 soll installiert werden
                       Hängt ab von: libpython2.7 (>= 2.7) ist aber nicht installierbar
                       Hängt ab von: libstdc++6 (>= 4.5) aber 4.4.5-8 soll installiert werden
                       Hängt ab von: libzip1 (>= 0.8) soll aber nicht installiert werden
                       Hängt ab von: python-paramiko soll aber nicht installiert werden
                       Hängt ab von: python-pexpect soll aber nicht installiert werden
                       Hängt ab von: python-pysqlite2 soll aber nicht installiert werden
E: Unerfüllte Abhängigkeiten. Versuchen Sie »apt-get -f install« ohne Angabe eines Pakets (oder geben Sie eine Lösung an).

How can I force to install the packet?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

The package you downloaded is a deb package for ubuntu systems only. In your case with debian you will need to build the source version mysql-workbench-gpl-5.2.40-src.tar.gz and build it manually. The way to do this should be inside the tar.gz file.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.