Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've configured several of our outlook 2007 clients (connected to Exchange 2003) to use RPC over HTTPS. This allows our users to connect to the Exchange server remotely without having to connect using VPN tunnels.

All the computers are domain members, yet outlook refuses to remember the users credentials for connecting to the Exchange server, despite checking the remember password checkbox.

For info, the operating system on the clients doesn't seem to matter, WinXP, Vista and Windows 7 all show the same issue.

Does anyone know how to fix this?

share|improve this question

2 Answers 2

up vote 10 down vote accepted

This blog entry provides a solution:

Get Outlook 2003 RPC Over HTTP To Remember Your Password

On your client, you need to go into your Mail settings, then check your Exchange Proxy Settings.

  • Ensure that Connect using SSL only and Mutually authenticate the session when connecting with SSL are both checked on.
  • Enter in the Principal name for proxy server: in the msstd:frontend.domain.com format.
  • Select both the Fast and Slow settings.
  • Make sure the Proxy authentication settings is set to NTLM Authentication.

Now the real trick. Outlook will, when you select Remember my Password, store your password for the Back-end Mailbox server. But it does not save your password for the Front-end Proxy server.

  • Go into your Control Panel > User Accounts > Advanced > Manage Passwords.
  • Click Add, then type out the name of your Front-end server. This should be the same name as your SSL certificate on the default web site that contains the RPC virtual directory, put in your username and password.

It's for Outlook 2003, but I guess it should work for Outlook 2007 too.

share|improve this answer
    
Excellent, thanks for that. It's working perfectly. –  Bryan Jul 12 '09 at 11:20
    
On Small Business Server, NTLM Authentication is not enabled on the server side by default, so you;d probably have to go in and do that too. Does this technique work for Plain Text authentication too? –  Tim Long Jul 12 '09 at 11:32

The first thing to check is the type of account authentication you are using for outlook when connecting via RPC over HTTP. If you go into the RPC over HTTP settings page in outlook, you have 2 authentication options, Basic and NTLM, if you use basic, then it will always ask for the password, no way around that. Try changing to NTLM, this should let you save it. If it does not then you may want to look at the problems discussed in this KB article.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.