Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

when you navigate to you see an apache page showing a folder called, clicking there then takes me to which doesn't exist, so wordpress shows me the a 404 error. I'm trying to host a wordpress site at but I think I have some kind of directory listing wrong somewhere, though I'm pretty sure I've set up my /etc/apache2/sites-available/ correctly:

<VirtualHost *:80>
DocumentRoot /var/www/
<Directory />
Options FollowSymLinks
AllowOverride All
ErrorLog /var/log/apache2/error.log
CustomLog /var/log/apache2/access.log combined
LogLevel warn
share|improve this question

The only thing that looks off to me is this line:

DocumentRoot /var/www/

Change it to, drop the trailing slash, and restart:

DocumentRoot /var/www/


Next update

<Directory />


<Directory /var/www/>
share|improve this answer
I did that, still doesn't work – Diego Jun 4 '12 at 20:27
see the updated answer ... try that ...? – KM. Jun 4 '12 at 20:53
I did.... nothing :L – Diego Jun 4 '12 at 21:00
When you go this directory /var/www/ on the file system, what do you see? – KM. Jun 4 '12 at 21:04
I solved it by replacing the virtualhost line with my static ip. Weird. Thanks for the help! – Diego Jun 4 '12 at 21:04
up vote 0 down vote accepted

I solved this issue by replacing the

<VirtualHost *:80>


<VirtualHost my.static.ip:80>
share|improve this answer
The <VirtualHost> directive must match the NameVirtualHost directive exactly in order for it to be used. – DerfK Jun 7 '12 at 2:54

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.