Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I stumbled upon bad special characters in some manpages:

If your terminal is a "true" auto-margin terminal (it doesn▒<80><99>t allow the last position on the screen to be updated without scrolling the screen) consider using a version of your terminal▒<80><99>s termcap that has automatic margins turned off. This will ensure an accurate and optimal update of the screen in all circumstances. Most terminals nowadays have "magic" margins (automatic margins plus usable last column). This is the VT100 style type and perfectly suited for screen. If all you▒<80><99>ve got is a [...]

I have done some research. man uses $pager as its display tool and this is set to less in my environment. So apparently less is not able to display the man pages's special characters.

My terminal (putty) is set to Utf-8, and $LANG=en_US.UTF-8. What can be wrong?

share|improve this question
add comment

2 Answers

Try another pager (such as most).

PAGER=most man command_name

or

man -P most command_name

or

man --pager=most command_name

to see whether it can display the apostrophes correctly.

It may be that the source file (if any) for the man page is bad, the tools for processing the man page (*roff) are handling the character incorrectly, or the object file (cat file) those tools create may be incorrect. On some systems, you can regenerate the man page object files.

Run man with one of these options (-W, --where-cat or --location-cat) to see where the cat file is located. Try renaming (rather than deleting - so you can put it back if necessary) the cat file so a new one gets generated.

You might try specifying the encoding to see if it helps. Try UTF-8 and UTF-16, for example.

man -E UTF-8 command_name

or

man --encoding=UTF-8 command_name

Finally, run mandb to check the cache consistency.

share|improve this answer
add comment

See first if you have LESSCHARSET environment variable set.

echo $LESSCHARSET

If that is not utf-8 already, then set it:

export LESSCHARSET="utf-8"

See if that helps. You may also try a pager called most, it's available at least on Debian/Ubuntu package repositories.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.