Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I just set up an new DirectAdmin, and I want to prepare it for IPv6 use. My ISP have gave me an range of IPv6 addresses that I can use. Lets say that address is 2a01:7c8:**:1f::.

My neworkadapter user DHCP to resolves its IP-addresses. When i type ifoncig eth0 I get the following result:

eth0      Link encap:Ethernet  HWaddr 52:**:**:**:ce:f3  
          inet addr:37.**.**.44  Bcast:37.**.**.255  Mask:255.255.255.0
          inet6 addr: 2a01:7c8:****:1f::/64 Scope:Global
          inet6 addr: fe80::5054:ff:fe87:cef3/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:38941 errors:0 dropped:0 overruns:0 frame:0
          TX packets:29439 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:3779534 (3.6 MiB)  TX bytes:5089379 (4.8 MiB)

As you can see, I have an IPv6 address set, but I can't ping6 an IPv6 host. I get the error: connect: Network is unreachable.

I decided that I needed an gateway, so I tryed to add one: ip -6 route add default via 2a01:7c8:****::1 dev eth0 (2a01:7c8:**::1 is the gateway of my ISP).

But it trows an error: RTNETLINK answers: No route to host.

Does somebody know what to do, and how to solve this issue? Thanks a lot!

share|improve this question

1 Answer 1

Maybe because the gateway is not in your subnet. You'll need to un-obfuscate your addresses so that we can tell. It is odd that you're using the all-zeros address for your eth0. That's probably not correct.

You also should be using your distribution's methods for making these settings permanent via configuration files, rather than entering them at the command line after every boot.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.